スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

macでemacs -nwを使うとriskyと言われる

mac osxには標準でnw版のemacs 22が入っているのだが、init.elに23用のプラグインが入ってるとエラーになります。
こんなかんじで

signal(error ("Unknown keyword :risky"))
error("Unknown keyword %s" :risky)
custom-handle-keyword(package-load-list :risky t custom-variable)



Emacs.appに引数を付けて呼び出せば新しいバージョンを呼び出せます。

/Applications/Emacs.app/Contents/MacOS/Emacs -nw



しかしこれは間抜けだなあ。と思い、解決策を考えました。

which emacsでデフォルトemacsの場所をさがし、どこかにバイナリファイルを移動、その後ソースをダウンロードしてコンパイルすると新しいemacsがインストールされ、nwでもちゃんと開くようになります。
上書きはしないようなので、移動しないとダメです。

スポンサーサイト

Leave a reply






管理者にだけ表示を許可する

Trackbacks

trackbackURL:http://epigonen190.blog.fc2.com/tb.php/46-66fc3934
該当の記事は見つかりませんでした。
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。